Astar 4.3.29 Does not show Grid graph in Scene view

Unity 2020.1.0f1, URP 8.2.0 and newer
Astar 4.3.29 Does not show Grid graph in Scene view. Show graphs option and All gizmos are turned on.
If I turn on gizmos in Game view, Grid graph will be visible in Game view only.

1 Like


Try to upgrade to 4.3.30, I have made some fixes to URP support there.
Make sure gizmos are enabled in the scene view too.

Still not working for me in 2019.4.5f1 and HDRP 7.4.1. :frowning:
Also turned all gizmos on, but nothing in scene or game view.

Could you send me screenshots of your setup?
Make sure you have selected the game camera at least once as Unity then attaches some script to the camera.

The update does not help me. Now AIPath Gizmos not visible too in Edit mode! But still visible in Game mode.

Also each time I press Scan I got:

EndLayoutGroup: BeginLayoutGroup must be called first.
Pathfinding.FadeArea:End() (at Library/PackageCache/com.arongranberg.astar@4.3.30/PackageTools/Editor/EditorGUIx.cs:132)
Pathfinding.AstarPathEditor:DrawSerializationSettings() (at Library/PackageCache/com.arongranberg.astar@4.3.30/Editor/AstarPathEditor.cs:871)
Pathfinding.AstarPathEditor:DrawMainArea() (at Library/PackageCache/com.arongranberg.astar@4.3.30/Editor/AstarPathEditor.cs:383)
Pathfinding.AstarPathEditor:OnInspectorGUI() (at Library/PackageCache/com.arongranberg.astar@4.3.30/Editor/AstarPathEditor.cs:262)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr, Boolean&)

@Aron -> I wrote you a pm.

@eric_kirschstein I did not have access to the folder you shared.

From what I can see in your screenshots you have unchecked all visualization options in the graph (Show Surface/Show Outline/Show Connections).

I clicked all on/off several times. Its just a bad screenshot.

I dont know how - i didnt change anything in the scripts or in astar, but it got fixed after unity reimported something after i merged another branch into my git project. No idea what happened - but luckily i can see the graph now.

Are you guys using Tilemap, URP/2D Renderer? The graph wasn’t showing for me no matter my settings. I found that if you bring up Tile Palette and set Focus On to something other than None, the graph gizmos finally show up. I sent @aron_granberg an email with more information. There are some other issues like unwalkable node settings not updating.

I don’t think this was happening in previous beta versions.


Ah. It turns out the 2D renderer does not have enough features to be able to support the gizmo drawing system :frowning: . Hopefully it will get the necessary features soon. Right now I think it’s impossible for me to implement support for it.
I have added a warning now when it detects you are using the 2D renderer and this will be included in the next update.

The Focus On toggle probably overrides the renderer to some other renderer which does happen to be supported.


I can confirm it worked in earlier versions of A* beta, this only changed a couple updates back. Are we able to use a legacy version of just the graph gizmos? Would the new version (4.3.31), prevent the Focus on tilemap trick from working? Kind of need to see those graphs and unwalkable nodes to debug :o

Btw, we’re still able to use ppv2 on some versions of URP. I’m currently still using it. Maybe this is what you changed a couple updates ago. How does this work for the built-in pipeline? Are you doing a check for URP and then attaching custom renderer features for all versions of URP? If so, where in the code can we disable this to make it work more like the builtin pipeline (assuming, it should still work, yeah?) You might need an additional define to check for ppv2, (UNITY_POST_PROCESSING_STACK_V2) if it’s a matter of post processing incompatibility.

You could try to find the DrawingManager.cs script. Then find the RefreshRenderPipelineMode method and then make it always set

detectedRenderPipeline = DetectedRenderPipeline.BuiltInOrCustom;


Thanks for the tip but doesn’t seem to work.

I would think it would since I’m using ppV2 but I guess not. If you can’t get it working, the tile palette Focus trick at least makes it show up for now, but not well. For example, the 2D lights seem to interfere with the graph tiles & unwalkable nodes. I may have to hook my events to a tool to disable them while debugging.

I’m not sure what’s holding up Unity’s status with 2D Renderer, but the lack of custom renderer features is concerning at this point.

I just ran into this issue where 2D graph visualization stopped working after upgrading from 4.2.15 to 4.3.38 (Unity 2020.1.16f1 and URP 8.3.1).

@aron_granberg any chance you could take a stab at fixing 2D graph visualization when using URP? As a data point, I downgraded back to 4.2.15 (free version), didn’t change any of my rendering settings within Unity, and graph visualization works flawlessly. I’d really like to upgrade to 4.3.38 (pro) and start using some pro features, but not being able to visualize the path graph is a deal breaker. The ‘tilemap focus’ work around discussed previously in this thread does not work consistently. I got it to work a couple times, but have not been able to get it to work since.

Also, not sure if it’s well known, but the ‘Graph Display’ menu in the scene view is hidden behind the Tilemap Focus menu (resizing the scene view does not help):

Graph Display hidden behind Tilemap Focus

If you’re using the URP and having issues seeing the gizmos try adding the AlineURPRenderPassFeature as a render feature to your forward rendering data asset. Personally I couldn’t see the gizmos in 4.3.29 and Unity 2020.2 until I made that change.

1 Like

@Jakob Hmm, it should be doing that automatically…

Perhaps it had something to do with me manually downloading and importing 4.3.x instead of using UPM?