Astar 4.3.29 Does not show Grid graph in Scene view

I don’t think so… Maybe something has changed in newer versions of URP though.

it does not work for me either with URP in Unity 2020.2.4f1 and A* Pathfinding Project v4.3.41
I don’t see the grid… ?! (i have checked show surface, show outline, show connections and show graph)
… and i don’t have the ALINE asset for the fix above…

EDIT: I have buy ALINE now. It works, but i think ALINE is not active for faster displaying my grid?! It is very slow…


A* uses an internal reduced variant of ALINE to do its drawing. It should’t be affected by if you have purchased the ALINE package or not.

What kind of performance issue are you seeing? Do you have a screenshot of the profiler?

Hi @aron_granberg, I’m still having this exact issue where graphs are not drawn in the scene view (with Gizmos enabled and Show Graphs also enabled). This is while using the latest version of Astar (4.3.41 Pro), Unity 2020.3.0f1 and URP 10.3.2. When I downgrade to Astar 4.2.15 (free) graphs will display correctly in scene mode with Gizmos enabled and Show Graphs also enabled (with no other changes to the project, scene, or Pathfinder settings).

Might be worth noting that URP’s Forward Renderer does support render features. Not sure what you’re using to draw the graphs in scene mode, but if it’s post processing functionality you can find in URP’s Forward Renderer, then that should work. If it’s post processing functionality that is completely lacking from URP’s 2D Renderer then that may be the problem, and might require some sort of work around. But I will say that whatever you were using in 4.2.15 (free) is working as expected, so it seems likely that some change in how graphs are rendered between 4.2.15 and 4.3.x is worth investigating. Maybe if you can track down how graphs are rendered in 4.2.15 you could just add a conditional statement that detects whether URP and the 2D renderer is being used and then switches to using the 4.2.15 rendering code (not ideal, but it may work until URP’s 2D renderer fully supports custom post processing, or whatever functionality you currently require).

@krice are you using the URP 2D renderer?

Yes, unfortunately there are some issues with that. The 2D URP does as you say have very limited features.
How graph rendering was done has changed very significantly between 4.2.x and 4.3.x. But it has indeed caused some problems :confused:

@aron_granberg, yes, sort of. I’m using camera stacking with two cameras. The parent camera is using URP’s forward renderer, and simply frames the scene (camera movement, depth, etc). The child camera is using URP’s 2D renderer, and that’s the camera that is rendering the scene. Incidentally, using URP’s forward renderer on the parent camera allows me to apply a full screen custom post processing effect obviating the 2D renderer’s lack of render features for post processing.

How does graph rendering in 4.3.x choose the camera to render to? Is it simply using Camera.main? And is there maybe a field exposed that users could explicitly assign a camera to that renders the graphs? I’m curious to know whether 4.3.x is attempting to renderer to the main camera (which in my case uses URP’s forward renderer) or the perspective camera (which uses URP’s 2D renderer). If we can identify which camera graphs are attempting to be rendered to then we may narrow down the problem.

@aron_granberg Have this issue being solved ? Just came by and looking for an answer but I found nothing helpful thanks

Thanks! This fixed it for me.

I just tried using A* 4.3.47 beta, URP 10.6.0 and Unity 2020.3.19f1 and graphs do not show in Editor Window

One thing that I find interesting and not sure if it help but while the graph does not display in the scene view when not in play mode, when I am in play mode in the editor, the graph does show up in the scene view.

Any reason why it would only show when playing the game in the editor (using the 2D Renderer)?

I wanted to comment my experience with this issue, because after solving it I still have zero clue what fixed it.

I am on:
Unity 2021.2.12f1
Astar 4.3.48
Using a Universal Render Pipeline (I don’t know too much about the render pipelines)

First off, I did add the Aline URP as a Render Feature as suggested above. That didn’t fix the issue, but I left that in there.

After bouncing between a completely stripped down scene that had none of my script running in it and the sample scenes, I couldn’t find anything different between the A* components in both scenes, but in the Sample Scene I could see the graph while I could not in my own scene.

What I did to fix it was delete the Pathfinder script off of my A* game object. I then copied the Sample Scene’s Pathfinder script component and pasted it onto my A* game object. This fixed it. I have no idea why. All the values look exactly the same.

My only guess is that for some reason I had an older version of Pathfinder on my A* game object that didn’t update (somehow?) when I updated Unity and/or the A* project. I hope this helps someone.

1 Like

I’m having trouble seeing the gizmos too anyone got a clear solution for this? Im using URP.

just want to +1 this issue so its known that its still happening.
I’m not getting any scene view rendering of Astar graphs.
I’m using URP in a 3d game.

A* is 4.2.18 Pro
Unity is 2022.1.24f1
Pipeline is URP, default settings.

I’m considering buying ALine to try the fix but would rather not throw more money at it…
I also tried upgrading my game to Unity 2022.3 so that i can use the new A* 4.3.66 but the upgrade broke things in my game, so I’d prefer to remain on 2022.1.

Edit: nevermind, I’m embarassed. Apparently there are many ways to hide gizmos in Unity. In my case, I opened a fresh scene, had the same issue, but clicked a bunch of stuff and I didn’t realize this little sphere icon had to be highlighted in the upper right corner. My mistake! Enabling this brings them all back.