Support Forum

NavMesh not showing

Hey!

Just started with all this. Unfortunately after scanning nothing shows up apart of that big box.


I have the terrain under the tag “ground”, obstacles are separate, as well as player itself.

Console just writes:
Scanning - Process took 60 ms to complete
UnityEngine.Debug:Log(Object)
d__141:MoveNext() (at Assets/AstarPathfindingProject/Core/AstarPath.cs:1784)
Pathfinding.AstarPathEditor:MenuScan() (at Assets/AstarPathfindingProject/Editor/AstarPathEditor.cs:1430)
Pathfinding.AstarPathEditor:OnInspectorGUI() (at Assets/AstarPathfindingProject/Editor/AstarPathEditor.cs:265)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Let me know, if I you need some info :slight_smile:

Hi

By gleaning info from the screenshot in your other post. Are you sure all the (relevant) objects in the scene have the ‘Ground’ tag set? Try removing that tag from the recast graph settings and see what happens.

Changed “Ground” back and forth everywhere. Nothing happens.
Those GameObjects come from Blender’s FBXs - maybe there’s something wrong?

//Uploading stuff just becouse I can and don’t know what might help :slight_smile:

Made a video as well… I think I did all right…

Hmm. Maybe the surface area is too small. Try reducing the ‘min region size’ setting and see if anything shows up.

Nada :frowning: Nothing between -300 and 300.

Do the example scenes work for you?

Since you ask… actually they do not :confused:

Ah, you are using a render pipeline.
Which version of the package are you using? And which render pipeline?
You could try the beta version (see https://www.arongranberg.com/astar/download) which has better support for render pipelines.
I didn’t think the 4.2 version failed to show graphs in other render pipelines… but maybe it does.

It was 4.2, but I installed 4.3 and it’s the same - does not scan.

And I cannot check the example scenes, as this time they did not show up under the assets :confused:

In 4.3 you have to import the example scenes in the package manager. Scroll down to the bottom of the package manager window and you should see an import button.

Oh. Did that. The same pink galore :frowning:

P.S. I use URP.

Created another project, this time non-URP - example scenes worked smoothly.
But it still refuses to generate an area on my terrain :confused:

  • objects from which the terrains is made have a tag #Ground;
  • min region size was anything from 0 to 3;
  • no errors showed up

Hi

Do you think you could make a small example project which shows this issue and send that to me?
I have no idea what is causing this and it would be interesting to know if I could replicate it.

Also. Have you checked the ‘character radius’ setting on the recast graph? Try reducing if it is larger than about half the width of that object.

Sure! I’ll send you this one later today, no probs. What would be the e-mail?

You can send me a direct message on this forum with e.g. a https://send.firefox.com/ link.

Sent!

Just all in one Zip.

Hi!

I just wanted to say that I have the same issue with a grid graph. I followed the Beginner tutorial on my own Universal Render Pipeline project using Unity 2019.3 and cannot see any grid even if the AI works properly. For the gizmo, I can see red boxes where the AI cannot go but not the grid at all. I did check if everything was setup properly with tags and layers and it is.

The test scenes seems to work though, even if there is the error color for shaders due to wrong conversion to URP.

@LoloDev

@Olafs_Osh’s issue was resolved as it was due to incorrect recast graph settings.
Do you think you could send a screenshot of your settings @LoloDev?

Ah, it works in URP! Nice.