Issue connecting mesh to terrain

For some reason, all of my doorways never connect to the terrain below. I’ve turned down all my settings to super high quality (character height, radius, cell size, etc) and made sure the character can go on the step (should be able to, since it correctly navmeshes stairs that is wayyy bigger steps). I can only guess it has to do with the combination of mesh and terrain, somehow. I’ve also tried setting the collider detail to 2000, just for fun. No matter what I do, it never works.

EDIT: This only seems to happen if its using colliders. If it’s basing it off meshes, it correctly connects. What’s odd is that these meshes have mesh colliders, so there shouldn’t be a difference, since I have a super high collider detail… Bug?

I’ve had the same issue when the height of the bounding box is smaller than the height of the objet which is cutting into the mesh, in this case the doorway.

1 Like

Do you mean the walkable height? I tried making it very small and it still didn’t work :frowning:
And since rasterizing meshes works, but rasterizing colliders (it’s using a mesh collider) does not, shouldn’t the outcome be the same? :confused:

Just thinking, what Graph Type are you using?

1 Like

I’m using the recast graph :slight_smile:

Another thing, is the doorway mesh touching the terrain, as that might stopping the connection?

1 Like


I don’t really see anything wrong at first glance.
So I’ll test a similar case on my end to try to recreate the issue.

For now could you also post a screenshot with collision debug visible.

To do this go to Window > Analysis > Physics Debugger

1 Like

Turns out I am just very very dumb. I forgot I have a special collision sphere that only collides with weather particles, but of course I forgot to remove that layer from the recast graph. AAAAHG

Well, thank you for helping! I instantly figured this out once I turned on the physics debugger :^) stupid stupid