A* Pathfinding Project

Graph Collision position doubt


#1

Hi! we just purchased the pro version of this amazing asset!.

I have a little doubt about the collision testing that im using on my GridGraph. I set the GridGraph to place capsule colliders in the street layer![27|612x396] tiles. It works well but since it places the colliders at the extremes of the tile I can’t get an accurate result with it.
Is there a way to set these colliders to be placed in the center of the tile?
The reason of this is our ships should not be able to cross when the street (bridge) is there, but when I remove a street tile, there should be space enough. But since the colliders are situated at the extremes there is not enough space. This would be fixed if the colliders would be set at the center.

Here I show you the colliders being situated at the extremes
and the street tile from above that belongs to the streets layer:
00

Here my grid settings:

Thanks in advance!!!


#2

Hi

The system always checks for collision in the center of each node.
It sounds like you want to offset the graph by half a node along the x and z axes to make it line up with your game’s nodes.


#3

ooooh!!! Makes sense, of course, I’ll try that.
Thanks for your fast response again Aron!!!


#4

Now Im getting a different problem, this tile has no street but still is placing a collider there.

Im playing with the values height and offset and the colliders change but always there’s one out of place


#5

Solved!
Using ColliderType RAY solved the problem :smiley: now I have the colliders exactly how I wanted.
Thanks !!!