Colliders are not working


I have a 3D Tile based system and I am trying to limit the path finding on the sides of my slopes/ramps by adding invisible colliders, a suggestion I found on the forums. However, when I scan it is still linking nodes on the sides of my slope. I would have included an image to explain this better however since I am a new user I am unable to.

I also have the colliders on a GameObject with the layer “Barrier” and checked Barrier in the Mask field under Collision Testing.

Any help would be appreciated.

Here is a link to an image showing the colliders and the path grid.


You probably want to increase the resolution of your graph and then adjust the Max Climb setting.
There is no raycasting that is done for the connections between different nodes, it only checks height values.

I’m sorry but I don’t know what you mean by the resolution of the graph.

I am currently using 96x96 nodes with a node size of 2. What I am trying to achieve is a single node in the center of each tile to have a very sharp/blocky looking movement which is working except for the slopes.

What I meant was to reduce the node size.
Essentially you are having the same problem as this post (just a few days old): Need help with layered grid graph

I guess the easiest way to solve this is to add some additional functionality to the grid graph which does a raycast on a specific layer for every connection. That is not particularly fast, but it’s a small graph anyway so it doesn’t matter much.