4.2 vs 4.3 Performance and 2D URP Support

So I know about the warning that with 4.3 beta gizmos as such might not work with the 2D URP which I am using. This was making working with this tool a lot harder since I would have to run the game to see the gizmos (not sure why the gizmos always work when playing but they seem too).

So I decided to try out the 4.2 non-beta version and the gizmos seem to work fine however I noticed that my frame rate went from 170FPS to like 70FPS (nothing other than the version of this project changed).

So I have 2 questions:

  1. Is this level of performance difference expect between 4.2 and 4.3?
  2. Any eta on gizmos support for the 2D URP while not in play mode (again the gizmos seem to always work when in playmode)?


Sorry for the late answer.
The 4.3 gizmos are definitely more optimized. So the performance difference is expected.
I see that the 2D URP now seems to support the necessary features, so I’ll probably investigate supporting that soon. I can’t give you a fixed eta though.

From what I can tell, the 2D URP now has the necessary features, and it seems to support everything ALINE requires out of the box. In my tests all gizmos work as expected even in edit mode. So the warning can be ignored.
Do you still not see any gizmos in edit mode?

Still not seeing them in edit mode with version 4.3.47 / Unity 2021.2.7f1 / URP 12.1.2.

Weird. Are you using any kind of post-processing or plugins? Do the example scenes work? Are you sure you have enabled gizmos in the scene view?

I have a render feature from another library I am using (though same issue even when I remove that). the gimzos are enabled (they still show up when I am in play mode) and I honestly can’t find where to get the demo since they are no longer including in the main package.

You can find the examples by going to the package manager and importing them. They are listed at the bottom of the package view.

The RVO 2d examplei s worse as it does not show the grid in either edit or play mode

Do you think you could check if this happens in a new empty project for you?

Same issue on a clean default 2D URP project, no grid gizmos when in edit or play mode on the RVO 2d example.

Would it be possible for you to share that small project with me? I think something is different about our setups.

I can zip up the default project to 8MB but how do I send it to you?

Dropbox or any other file sharing service?

Let me know when you downloaded it so I can delete it:


I downloaded it and opened the 2D RVO example scene. The gizmos seem to work perfectly fine for me:

What operating system and graphics api are you using?
Can you try to open the aline_outline shader in the Unity inspector and see if there are any warnings logged?

Do you know if the gizmos work if you are not using the 2D URP?

Note that graphs only show up if you have scanned them. So make sure you have selected the A* component and clicked Scan (or ctrl+alt+s).

It does not work for me:

I am on windows 10:


the aline outline shadow look like this with no errors / warning when I select it:

I know I have to scan it and it works fine with playing on not using the 2D renderer.

I have no idea hat you mean by graphics api (DirectX vs OpenGL?) but I am using whatever the default it, the project I sent you I made 0 changes outside of installing the astar pacakge.

Are sure you are using the same Unity version?

@aron_granberg, @ryanzec, which URP renderer asset are you both using? Your camera will be configured to use a renderer under Camera → Rendering → Renderer. It’s possible that the two of you are using different URP renders (Forward Renderer vs. 2D Renderer). My guess is that the graph gizmos are working with the Forward Renderer, but not with the 2D Renderer (I mentioned this in a previous post).

I might be wrong but it working with the Forward Renderer it useless for my case as when working with 2D and the URP, from my understanding, you have to use the 2D Render Data (as the Forward Renderer is for 3D).

So really weird thing I am seeing now. If I load Unity and try to rendering the grid graph overlay, it does not work. Now however if I switch from the game view (not playing it or anything) and then back to the scene view, the overlay shows up. it will update and everything, not sure why.

Only different is that I re-installed windows (still windows 10) so not sure why that would have done it (though I re-installed because I was notice other issues and I like to do it every so often).

Yeah, I’m not suggesting switching to the Forward Renderer, rather tracking down the discrepancy between the behavior you are reporting and the behavior @aron_granberg is observing; identifying the configured URP renderer of the camera the two of you are using is a pretty significant piece of the puzzle.