Pathing through walls


#1

I’m using Layered Grid Graph where the intent is the AI can walk on top of walls, as well as around them. I’m finding an issue where if I intentionally set up a scenario where the destination is unreachable, the AI will try to walk through walls to get there.

In the screenshots, the ground has the layer “Ground” while the 4 blocks have the layer “Default”

You can see that the destination point is completely surrounded by grid nodes with a red cube, so is unreachable. Also, the max climb is 1.169192 while the cubes are like 43 meters high.

If the wall was < 1.169192 meters high, the AI should step up onto it. > 1.169192 it should block pathfinding. At least that is the intent. If instead the wall was raised up off the terrain more than the character height (1.959236) I would like the AI to walk under it.

Using version 4.1.9

My character settings:

Height testing

Obstacle Layer mask:

All settings

Update: Upgraded to 4.1.10 (Pro) and the issue still happens


Path endpoint rounded off causes failure to reach destination
#2

OK so the issues seems to be Seeker. I had End Point Snapping set to Original. But it wasn’t really clear what “The point is set to the exact point which was passed when creating the path request” meant; I interpreted it to mean walk to the point I set, instead of stopping earlier which happens with SnapToNode for example. But I didn’t mean for it to walk through walls too.

It kind of seems like NodeConnection is what I want, but I’m still not really sure what “The point is set to the closest point on one of the connections from the start/end node” means. What I want is "Reach the exact destination if you can, otherwise get as close as you can.


#3

Hi

I have updated the documentation with pictures to better illustrate the different modes. Hopefully those will help:
https://arongranberg.com/astar/docs/startendmodifier.html#Exactness

TL;DR Is that you want the ClosestOnNode mode (which is also the default value unless you are using an old version).