Support Forum

What to do when I bought Aline and Astar at same time

I bought and imported Aline when the project has already used Astar. Now it created bunch of errors related to .asmdef since both of them apparently using a few same files.

Should I simply delete either ones or should I do something specific here?
And it seems Astar already using Aline, does that mean I could’ve already used Aline even Not purchasing Aline?

Regards,

Hi

Sorry about that. A bug in my build script caused them to conflict with each other.
I have updated the current beta version (I think only the beta conflicts with ALINE) to fix this.
I have also updated the ALINE package, it will be updated in the asset store within a few days most likely. Until then, you can work around the issue by changing the name setting in the .asmdef files in the ALINE package to be something unique.

The A* Pathfinding Project does use a subset of ALINE for rendering the graphs and some gizmos. However this is a very limited version and it’s not intended to be used outside the A* Pathfinding Project internals. Previous beta versions have included the full ALINE package simply due to me not having finished the build script for stripping it down to the parts that the A* package uses. The latest version is more stripped down and will not be very useful on its own.

Hi there,

  1. Updating Astar to 4.3.23 and changing Aline’s drawing editor .asmdef’s name to st else fixes said issue.
    (BUG) However, now I don’t see the debug drawing anymore. No Drawing in either AIPath nor Seeker. It appears and disappears instantly when in playmode and that’s it. Nothing changed except above mention.

  2. Also in Aline GetStarted document, MonoBehaviourGizmos’s inheritance is required for override DrawGizmos but in previous AIPath, No MonoBehaviourGizmos’s is inherited and still override DrawGizmos is being used and everything works just fine (except for now nothing works as mentioned above). Did I miss something?

  3. I intended to ask for a refund if Aline is already included inside Astar. Hearing from you cleared my doubts since I found it weird for such a clean and apparently highly-polished asset to be fully included like that. This is such a very good asset if fully developed and worths the price so no regrets there.

  4. Can I use Aline to draw s.t like Danger indicators (showing enemy’s next target/next position to damage) in-game? Like a bomb throwing and a red circle appears at destination and gets larger overtime, is Aline suitable for s.t like this or using a simple sprite better in this kind of scenario?

Best regards,
Hai.T.Nguyen

  1. That’s odd… Is it ok for you to wait two days or so until the asset store version of ALINE is updated? Then you can test that and see if it works.

  2. AIPath inherits from VersionedMonoBehaviour which inherits from MonoBehaviourGizmo.

  3. Thank you for the kind words :slight_smile:

  4. You sure can.

IEnumerator ThrowBomb() {
    float startTime = Time.time;
    while(Time.time < startTime + 2) {
        Draw.ingame.CircleXZ(transform.position, (Time.time - startTime)/2.0f * 0.3f, Color.red);
        Draw.ingame.CircleXZ(transform.position, (Time.time - startTime)/2.0f * 0.4f, Color.red);
        Draw.ingame.CircleXZ(transform.position, (Time.time - startTime)/2.0f * 0.5f, Color.red);
        yield return null;
    }
}

If a sprite or ALINE is better in this case depends a lot on what aesthetics you want. ALINE will give you crisper lines. But they will only be 1px thick.

1 Like

Awesome, I’ll try it out.
Will update when I can get the latest version of Aline.

Newest version works like a charm :smiley:
Is there any way we can have a solid circle, just like solid box?
Also there’s a tiny inconvenience that whenever I type “Draw”, Rider suggests Pathfinding.Drawing and Aline Drawing(second line, have to move down). So sometimes my quick fingers made mistakes. It’s not really a big deal though. Just let you know.

Actually the bug is still there, just inconsistent on its appearance. After first installing of the new version, everything works like a charm. Today I found no Drawings in scene nor out. Don’t really have a clue here so I’m making a new fresh project to try to find a solution. Kind of loss here.
Hopefully you could have a better luck pinpointing the issue.
Unity 2019.3.12, Latest version of Astar (beta) and Aline

*UPDATE:
Installing Aline, run a test script (drawing a simple circle when selected) and it’s fine
Installing Astar 4.3.24, Aline drawing is still visible, but nothing (not debug lines, not grid lines) is showing, even in demo scenes.

*UPDATE:
Downgrade Astar to 4.3.21 and everything appears again, but I can’t use Aline unless it’s 4.3.23+.
It seems to me this is likely an Astar’s bug, not Aline’s.
Please help.

Oops. That was a very silly bug. After my build script had run, no gizmos would work in the whole package. Sorry about that.
I have uploaded version 4.3.25 which fixes this.

1 Like

Currently there’s still no drawings of AIPathing (usually there’s several circles, now is none)
The below works normally:

  • Grid shows
  • Aline drawing shows
  • Other asset debugs shows
    I’ll try replacing Drawing of AIPathing with Aline to see how it works
    *UPDATE
    Changed AIPathing’s Drawing to Aline’s Drawing seems fix nothing.
    Showing debug all the time is checked and Gizmos view is enabled.
1 Like

On above issue, I found out that Astar drawing works fine. But my AIPath (using 90+% of Pathfinding.AIPath) which has showed debug before, now doesn’t.
I created an empty class with only VersionMonoBehaviour, Using Pathfinding and Draw in DrawGizmos and it was still not showing anything. But again, Pathfind.AIPath does show.

I tried to replace all Drawing in AIPath into ALine Drawing but VersionMonoBehavior is not supported by ALine, which is the end of circle.

Is there any chance you put some kind of limit in this case?
Maybe add support VersionedMonoBehaviour onto ALine, or if it’s short, post an solution here so I can copypaste?

1 Like

Ah, right.
Another fix.

I’m uploading 4.3.26 right now which I think should fix this once and for all.
It should be uploaded in a few minutes.

1 Like

Great! It seems working now.Thanks for your support. Hopefully this is the last time I post here :rofl:

1 Like