vectorPath is empty but the debug log says there is a path

This is the first time trying to use A* Pathfinding Project and looks perfect for what I want. Tried following the docs and I think I have everything setup right.

I’m trying to use this as a very simple 2D pathfinder and seem to have it all setup fine. (everything lines up in the editor)

Width 20
Depth 10
Node size 1
aspect ratio 1

center 10, 5, 0 (z is as close to zero as it will let me 6.890912e-15)
rotation -90
cut corners false
connections four
no collision
no height

I simply use StartSearch(transform.position, goalPosition)
transform.position = (0, 5, 0)
goalPosition = (19, 9, 0)

in debug I get

Path Completed : Computation Time 0.00 ms Searched Nodes 19 Path Length 19

but my vectorPath.Count is 0

path.error is false

Doesn’t get a path and I don’t know why. I’ve tried searching the answers but I am not finding anything.

Anyone know a possible cause for this or what I might be missing?



seems to have been I was starting at 0,0 and the grid doesn’t like that. If I start at .1 then it gets a path. Problem is that it skips nodes to get to the goal node. I thought I saw another post about that so I’ll go searching

I figured out all my problems. I didn’t set the “Ground” layer so it was all screwed up.

For others that encounter this… I was having this issue when capturing the return value of my _seeker.StartPath() call. Instead, I used the overload with the delegate and everything worked fine:

_seeker.StartPath(transform.position, targetPosition, OnPathComplete);