Using Post Processing with URP : lines are not hidden when behind gameobjetcs


When I enable post processing on my camera (using URP), the lines drawn by ALINE are not hidden anymore when behind gameobjects.
Maybe this is not supported ? Or did I miss something ?



Which version of ALINE are you using?


I use the version 1.2.2, in Unity 2019.4.1f1

Same here. 2020.1 beta.
There is some constant errors on console when grid draw is enabled too, but only on this beta version, not on 2019.3.

Would it be possible for you to post a screenshot of your URP settings?

Here is my URP settings :

And this is my ForwardRenderer settings :

I don’t know if this may be related, but I use a plugin from the Asset Store named HBAO to handle ambient occlusion in my scenes

What happens if you disable that? Is that the only kind of post processing you are using?

No even if I remove HBAO from project ALINE is drawned on top of the gameObjects

I use other post processings (Vignette, Color Adjustements, Shadows Mistones Highlights), but the problem occurs as soon as I enable the checkbox Rendering/Post Processing in the Camera component, even if the post processing profile is empty or the Volume component disabled


I have submitted version 1.2.3 to the asset store now which includes a bunch of fixes for URP. Hopefully they will resolve this. The update should go live in a few days once the asset store staff has reviewed it.


I updated ALINE in my project and the problem is solved, thank you :slight_smile:

It’s not something very important but I was wondering if there was a way to control the lines transparency throught gameObject, to makes them totally hidden for exemple ?

Nice! Good to know!

It is possible to change that in a material parameter. ALINE/Resources/aline_outline.material has a property for that. However, it’s kinda tricky to change package contents since unity introduced the package manager. But what you can do is to make a copy of that material and then assign that to DrawingManager.instance.gizmos.lineMaterial.

1 Like

I just arrived looking for a way to control the line transparencies (in my case, making them show more visibly) and this answer about the material was perfect. This got it solved in a few minutes, thanks!

It might not be super easy for everyone to do, but it’s probably still worth adding this to the documentation. I’d already searched through without finding anything about materials.

1 Like


I am using ALINE Version 1.4.1 and am experiencing the original issue where the lines appear even if they are blocked by game objects in game view, but not in scene view.


Does this happpen even in an empty scene with just a simple box or something (with a standard material)?

No it does not! In the new scene even objects that use URP material are behaving correctly. Is there some setting I should watch out for?

I’m not sure what could cause it. Maybe some post-processing effect on your camera?