[Unity 2017.1b8] Demo scenes do not work

Running the latest Unity 2017.1 beta with the experimental .NET API. All the demos fail to run unless I turn off threading entirely.

InvalidOperationException: The thread was created with a ThreadStart delegate that does not accept a parameter.
System.Threading.Thread.Start (System.Object parameter) (at /Users/builduser/buildslave/mono/build/mcs/class/referencesource/mscorlib/system/threading/thread.cs:329)
Pathfinding.GraphUpdateProcessor.EnableMultithreading () (at Assets/Plugins/AstarPathfindingProject/Core/Misc/GraphUpdateProcessor.cs:98)
AstarPath.InitializePathProcessor () (at Assets/Plugins/AstarPathfindingProject/Core/AstarPath.cs:1193)
AstarPath.Awake () (at Assets/Plugins/AstarPathfindingProject/Core/AstarPath.cs:1149)


Thank you for reporting this.
I will look into it.

In the mean time you can work around this issue by disabling multithreading (set A* Inspector -> Settings -> Thread = None).


I have fixed this now in my dev version. It will be included in the next update.
It is a very simple fix. Here is the diff if you want to do it yourself: https://pastebin.com/tGUvJbCA

Just wanted to report that I experienced the same error using v.4.0.11 - The fix above solved it. Did the fix not make it into the official update? EDIT: Apologies, didn’t realize the release and Beta are so far apart. Beta works fine.