Trouble with steps

This is really bizarre. Every time I try to walk up the steps, I get stuck as follows.

But if I record it using Quicktime, it makes it up the stairs.

Needless to say. I need to be able to walk up the stairs without having to have Quicktime running.

Changing the step speed solved the problem. Though it doesn’t explain the quicktime thing of course nor does it explain why it isn’t a problem under manual control.


I’m not really sure what could be causing that.
Though one thing that definitely looks wrong is that you have multiple AIPath components on a single GameObject.

The double AIPath issue didn’t appear to affect the problem, but clearly needed to be fixed.

A step speed of one works fine when you are manually controlling the character, but for some reason has to be raised to work when the AI is controlling the character.

I’m running Opsive’s Third Person Controller and they are saying that with stairs it is best to build an invisible ramp going up the slope for both smoother animation and that it can be tricky to get step recognition to work consistently.

I’m going to say that although the issue only occurred when running the pather, the problem lies elsewhere and can be easily worked around.

It’s hard to say really. You have a lot of scripts that seem to affect the character and I’m not really sure in which one of them the problem lies.