Support Forum

Steep terrain runtime navmesh differs from editor

Hi,

link: https://arturmandas.com/tempVids/navMeshRuntimDiffersEditorV2.mp4

Probably a noob issue, looks like there is an additional processing of the navmesh at runtime, erosion?

Best!

The issue is gone if I disable scanning on Awake and do that later manual scan via editor drawer at runtime, so probably postponing the scan would have solved it at runtime. The thing is, at some point I will want to serialize this - I have observed the scan from editor is still gone at runtime with scan on awake off - is there another switch for keeping the editor navmesh active in play mode?

Best!

@aron_granberg can you take a look at this? Looks like a bug to me. The same behaviour pertains to the situation when I have a serialized graph. It serializes fine but then at runtime it looks like some nodes are being cut out / missing, deterministically, exactly like on the movie. A* ver. 4.2.17

Hi

Are you doing any changes to the world when the game starts?

You can enable caching in the Save & Load tab, it does exactly that. Note that you need to regenerate the cache if you make any changes to the graph settings that you want to preserve.

Hi,

I’ve tried the cache, gives exactly the same behaviour. My thought was also that there must be some changes to the world, but what I do only is that I am doing tag and walkability changes to the world. Yet I noticed the same when I left enabled only the meshes that are totally static.

Best

I have observed the same for recast graph, can supply repro repo if that helps.