[Solved]Recast graph not casting for one piece of flooring?

I had a test scene here and the graph layer is set, it works for everything except my single tile. The tile is slightly raised but nor more than a quarter unit. It does get mapped if I use the collider version of graphing but not the rasterize meshes. I checked the model and read/write is enabled so not sure why it is cutting it off. Here are the settings:

I also increased the Y size of the graph to make sure that was not the problem and this was the result:


It is possible that the mesh has a slope along the side which is greater than 30 degrees. Even if it is small, the graph will not allow a slope greater than the one you have configured.
I’d recommend to not rasterize meshes here, since they look way more detailed than the graph needs. Use colliders instead. You can attach a RecastMeshObj to the object to choose between mesh and collider manually per object.

Nice, increasing the angle fixed it! Increasing the angle is not a big deal since most of everything I am doing is going to be flatish. Did not realize you could do a recast mesh object.