Seeker on Grid Graph with CapsuleCollider Collision test diameter 0,45 clearly slips through too narrow paths

With the Grid Graph Settings as in this picture, I thought it meant that each node represents a size of 0.1 x 0.1 units of space. The Collision Test is set to Capsule with a Diameter of 0.45. However clearly there is a path calculated which passes the 20cm (0.2 units) gap.

Update: Could it be that the reason for this is that the node size is affecting the collision test? When I set the collision diameter to 4.5 instead of 0.45 for a node size of 0.1 it seems to behave as expected. I thought the node size should only affect the amount of nodes and therefore the grain of the grid?


The diameter for the collision test is relative to the node size. So a diameter of 1 corresponds to a real world diameter of 1 * node size.

The paths can indeed cut corners a bit with the default settings. This is the most common option for grid graphs. You can make it more conservative by disabling the “cut corners” option.

1 Like