Seeker keeps generating path outside of the graph

Hi! So I suspect there might be an easy solution/setting for this and I’m just too dumb to find it after really days of trying and googling :frowning:

This is what my seeker does:

At certain edges (when I move the player close to the colliders, he is chasing the player) the path keeps getting generated inside of the red area :frowning: (this sucks, because it makes the seeker get stuck)
(disabling cutting edges didn’t fix this, but I’m also not sure I 100% what this does either)

Can someone tell me what I need to do?

Thanks! <3

Looks like you might have a SimpleSmoothModifier attached with a very high amount of smoothing. Try disabling it or reducing the smoothing.

1 Like

Ahh, thank you so much for the quick answer!

Gaaah, this really seemed to fix my problem :pleading_face: thank you sooo much!
I’ve already reduced all the colliders/obstacles intensely (for wrongly thinking this would fix anything) and now the enemy is too good :stuck_out_tongue_winking_eye: Hopefully it will still work when I rework those :smiley:


1 Like

Another Question related to this, sometimes the seeker still gets stuck when (I think= the center of the yellow circle (so the radius setting?) gets into the “no no area” (as I call it, haha).

Is there a setting to tell the seeker if it is in there to get out of it?
I still have smoothing on but reduced it, because without smoothing the seeker moves around very jittery :thinking:

Thank youuuu again! :slight_smile:

Edit: additional info to that: this for example is what happens, I don’t even understand why the enemy is stuck, as their collider AND the radius thingy isnt even colliding with the colliders/obstacles?
(They sort of “greyed” out round collider is a trigger and shouldn’t matter, right?)
What am I missing here? What do you think is the best way to fix this? :thinking:

I hope it’s okay for asking all this, and thanks again for answering and of course for the great Pathfinding package <3


Do you have a rigidbody, character controller or a collider on the player?

The smoothing that you have is most likely the cause of it generating a path outside of the blue nodes. You can try to reduce the ‘max segment length’ setting to make the smoothing a bit more high resolution.

Also, you may want to disable the agent’s Constrain Inside Graph setting if you are going to use smoothing.