Runtime Generation Odd Results

Hi, I’m brand new to this and purchased the Pro version; to be honest, I’m a bit overwhelmed by all the features and, though I’ve searched the docs and this forum, I’m not quite clear on why I’m getting the results I’m getting when generating a graph at runtime.

When I tried a grid graph, I got the “Path Failed” error. On the advice from someone on discord, I tried the recast graph, which seemed to work better but I’m getting very odd behavior and am not sure what I’m doing wrong. I have set obstacles to the obstacles layer and masked it but my npcs are still traversing through walls and boulders. Also, the graph seems to avoid grass, though I have set that to the default layer. I have attached recast mesh components to everything and set them accordingly. I have photos of what’s going on but they’re pretty basic.

I’m just not sure how to properly generate a graph at runtime and ensure that my npcs wander around correctly. I found that the paths seem to go “under” the obstacles and the npcs follow.

I realize this is the noobiest question ever but if anyone could explain the larger concepts or give examples, I would greatly appreciate it. Like I mentioned, I’m a bit overwhelmed by the possibilities of this project.

Thank you!

EDIT it seems that enlarging the character radius helped a bit but still running into some of those issues and the npcs kind of just stop when they hit the edge of the graph.


Do you have a screenshot of the graph and the path that is generated?