RichAI grounding raycast collides with triggers in wrong layer


I’m trying to get RichAI working for my pedestrian AI, raycasting for ground placement is set to true, ground mask is set to ground, and the intended ground surface is in the ground layer. However, I’m finding that the raycast my NPCs use for grounding is constantly colliding with trigger colliders set up around the PC, which exist in a distinct layer. Is there an easy way to fix this so NPCs can walk through trigger colliders while remaining on the ground?

Sorry for the late answer.

Um… are you sure those triggers are not in the ground layer? Unless Unity physics is broken, a ground mask set to “Ground” should only hit stuff in the ground layer.

If you want to exclude all triggers you can set Unity Project Settings -> Physics -> Raycast Hit Triggers to false.