Support Forum

RelevantGraphSurfaceMode

Hi!

We are currently on version 4.2.15 on Unity 2019.4.14.

I am trying to use the RelevantGraphSurface component with the RelevantGraphSurfaceMode RequireForAll, to get rid of navmesh in unwanted areas (under floors or stair cases).

However, when I turn on RequireForAll, ALL navmesh gets removed, even if I placed RelevantGraphSurfaces component on GameObjects in the scene.

Is there a way to make it work without coding a custom solution?

Thanks for your help,

note: I’ve seen this question asked a few times but didn’t find an answer to it, apologies if I missed it.

Bump :slight_smile:
Anyone has info on this topic?

Hi

That sounds odd, might be a bug there. I’ll check it out.
However, another thing which might be more relevant to you is the support for solid colliders in the beta version. In the beta all convex colliders are treated as solid, so no navmesh will be generated inside of them. This might solve the issue for you in a nicer and more robust way?

You can download the beta here: https://www.arongranberg.com/astar/download

Thanks a lot for your reply.
I did update my project to the latest beta version (4.3.43) and the same behaviour seems to happen.

This is a generation test in the project. You can see the settings on the right.

Same scene, adding a gameObject with the RelevantGraphSurface component on it (a few units above the ground collision) changing the Relevant Graph Surface Mode to Require For all and everything is gone.

I will test the convex colliders you mentionned see if that helps. But from my understanding the relevant surface would work better in our current setup.

Thanks!

Hi

Ah, it looks like I hadn’t ported the relevant graph surface code to the new burst powered scanning code. I’ve done that now and that will be included in the next update.

That doesn’t explain why it didn’t work for you in other versions though…

The RelevantGraphSurface has a max range. It must be at most that distance away from the navmesh to have an effect.

Oh that is good news. I’ll keep an eye out for the latest version. Thanks.

I was able to use the feature, but the results were a bit weird:

I only have 4 relevant surface nodes (circled in red), the navmesh under them is removed and navmesh in another areas as well.

When I set to Do Not Require:

Hmm, yeah that looks odd. I’d wait for the next beta update.

I tried the latest version (.45) and it works!!!
Thank you so much!

1 Like

For the record, this is with Unity 2020.3.11.