RecastMeshObj tag not applied to recast graph

Any idea why is RecastMeshObj is not working with recast graph?
No tags applied, no idea why :smile: am I missing something?

The debug colors are set to tag in Pathfinder component.

Are you sure the collider extends above the normal ground collider?

We use mesh as rasterization for the terrain, terrain itself has no collide (it’s custom mesh, not unity terrain)
However for recastMeshObj, I have tried to position it at various heights (the collide), still the same result, the tag won’t apply.

I note that your recast graph’s bounding box is only 0.5 meters tall. I’m not sure if this is an issue in this case, but I’d definitely increase it, to make sure all relevant meshes are gathered.

Yes I have already played with that, even setting it to higher values does not solve the issue.

After further lengthy investigation, it seems the RecastMeshObj does not work when Pathfinder has only rasterize meshes check.
It needs to have rasterize colliders checked ONLY for some reason. Is this intended?

as our “terrain” is just generated mesh, it has no colliders. We need to apply a tag based on some objects placed, like walls. But the RecastMeshObj is not working with this setup it seems, even though it has Mesh in its class name :slight_smile:

@aron_granberg any ideas please? Is this a bug? We are quite stuck on this issue.

I think I have managed to replicate and fix this.
It only happened when the RecastMeshObj was marked as solid.

A fix will be included in the next update :slight_smile:

1 Like

Hello @aron_granberg, I have updated to 5.0.8, and the mesh obj is still not applying the tag


Are you sure this object is included in the scan at all?
I see “Include In Scan” on the RecastMeshObj is set to auto. That means the recast graph will use the layer to determine if the object should be included.

It works perfectly fine for me:

I have set always include, and also the layer on which this object is, is Wall, which is also defined in AstarPath main component

however it still doesnt apply the tag. Any other setting we can check?

Any other way how we can mark some area to have different tag? Because thats the only way we need to achieve, so some agent can walk through some area with some penalty, other agent cannot

when I disabled “affected by navmesh cuts” it finally applied the tags… this seems to be some quite a nasty bug :grimacing:

discovered it while clicking and changing random values out of desperation.

But ofc we cannot keep this disabled, because now the regular navmesh cuts are not collected by navmesh and walkability is not affected


Ah, you were using navmesh cutting too. I see.

Yeah, this has been an issue with navmesh cutting. I do, however, have a fix for this in the pipeline. I expect that it will be included in the next update.

1 Like