RecastMeshObj disabling nodes it doesn't intersect with

Hey, so I’m using a RecastMeshObj to make an area of water unwalkable. The water is just a plane intersecting the terrain, and part of it sits underneath the terrain as it hits the shoreline.

So this results in a graph like this:

As you can see, for some reason the water plane disables the nodes above it as well as the ones it intersects. I’ve screenshotted the settings I’m using:

I also can’t seem to figure out how to specify points in the editor - when I deselect the object they just disappear. Any ideas?


It will disable all nodes it intersects, note that this is tested against the whole triangles, not just the centers of the triangles.
You might have some luck reducing the “Min Bounds Height”.

However the better option is probably to remove the GraphUpdateScene component and set the “Area” field on the RecastMeshObj to -1. I think that will give you the result that you want.
(I know that is not the most obvious thing to do, I should probably improve the UI for that).

When you create points, make sure you have the “Transform” tool active in the Unity scene view, otherwise Unity always seems to deselect the object all the time.

Thanks aron, that’s provided a workable solution by separating the areas - and in fact probably preferable as now I can use the water navmesh for water creatures. Thanks for the fast and helpful reply as always!