Recast Graph -- not connecting stairs like I expected

I am trying our the Recast generation for the first time, and I am not able to get some stairs included as part of the walkable area. I am including a screenshot below to show how the geometry looks. Is this a case where the stairs should have an invisible ramp modelled, or is there some Recast settings that would allow these steps to be added to the walkable area?

Update – I found that by reducing the cell size to 0.1, I got the connection on the stairs.

Is there any downside to using a 0.1 cell size, other than compute time? I just want to make sure there is no runtime downside to using a 0.1 cell size.

Not really, you usually want to use as low a cell size as you can while keeping the computation time inside reasonable bounds.

Hi Aron.

I’m having the same issue. Even with cell size set to 0.1
I have been able to just get around it by adding manual points. is there a better way of getting this to work?

Check your Max Climb and Max Slope settings on the recast graph.
Also Cell height can have some impact, but mostly the default should be fine.
Also check the Character Radius setting, if the character would be too wide for the stair, no navmesh will be generated there.