Support Forum

Obstacle as a Target: Newb Question

Hi all, just picked up A* Pro last week, so this may be a newb question, but is there a way to have an obstacle be a valid target. What I mean by this is that I am able to set an Obstacle as a target, but when my traveler reaches the [Obstacle target] it does not register as destination reached.

So here’s the example scenario

Goto Target 1 → once reached → Goto Target 2. (Works great)

where as
Goto Target 1 (Now on obstacle layer) → once reached → Goto Target 2. (Does not fire off the destination reached and does not set destination to Target 2)

I’m working on a little settles like game where the obstacles like buildings and trees often need to be targeted in order to enter a building or chop down a tree.

Anyhelp would be appreciated, maybe I’m thinking about it wrong.

PS: Using physics colliders instead of obstacles layers does work but my traveler will walk into things and slide around them. Thats why I would prefer to use obstacles.

Also just to add, I tried expanding the detection range of the traveler, it does not seem to make a difference. The detector is definitely overlapping the Obstacle Target but the code is not being triggered.

Solved it!

So far anyone experiening the same issue. If you want to use an obstacle as a target , you need to change the following settings:

AIPath: [When close to Destination] from Stop to "Continue to Exact Location’ and ensure that your
[End reached Distance] is extended enough away from your traveler to collicde withthe obstacle before the traveler does.

1 Like