Namespace Error after upgrading to Beta 4.3.63

I’m getting the error below when updating to the beta version 4.3.63. There are 41 errors in total, all related to the "CreateProperty’ . Was working perfectly fine with previous version of Astar.

Any ideas on how to resolve? Tried removing the dependency, but it just reverts. Installed using the package manager after modifying manifests.json

Library\PackageCache\com.unity.collections@2.1.0-pre.11\Unity.Collections\FixedString.gen.cs(5891,10): error CS0246: The type or namespace name ‘CreateProperty’ could not be found (are you missing a using directive or an assembly reference?)

Library\PackageCache\com.unity.collections@2.1.0-pre.11\Unity.Collections\FixedString.gen.cs(24,13): error CS0234: The type or namespace name ‘Properties’ does not exist in the namespace ‘Unity’ (are you missing an assembly reference?)

  "scopedRegistries": [
      "name": "A* Pathfinding Project",
      "url": "",
      "scopes": [
  "dependencies": {
    "com.arongranberg.astar": "4.3.63",
    "com.unity.2d.sprite": "1.0.0",
    "com.unity.2d.tilemap": "1.0.0",
    "com.unity.2d.tilemap.extras": "3.0.2",
    "com.unity.animation.rigging": "1.1.1",
    "com.unity.cinemachine": "2.8.9",
    "com.unity.ide.rider": "3.0.15",
    "com.unity.ide.visualstudio": "2.0.16",
    "com.unity.ide.vscode": "1.2.5",
    "": "1.3.2",
    "com.unity.render-pipelines.universal": "13.1.8",
    "com.unity.shadergraph": "13.1.8",
    "com.unity.splines": "1.0.1",
    "com.unity.test-framework": "1.1.33",
    "com.unity.textmeshpro": "3.0.6",
    "com.unity.timeline": "1.7.1",
    "com.unity.ugui": "1.0.0",
    "com.unity.visualeffectgraph": "13.1.8",
    "": "1.0.0",
    "com.unity.modules.androidjni": "1.0.0",
    "com.unity.modules.animation": "1.0.0",
    "com.unity.modules.assetbundle": "1.0.0",
    "": "1.0.0",
    "com.unity.modules.cloth": "1.0.0",
    "com.unity.modules.director": "1.0.0",
    "com.unity.modules.imageconversion": "1.0.0",
    "com.unity.modules.imgui": "1.0.0",
    "com.unity.modules.jsonserialize": "1.0.0",
    "com.unity.modules.particlesystem": "1.0.0",
    "com.unity.modules.physics": "1.0.0",
    "com.unity.modules.physics2d": "1.0.0",
    "com.unity.modules.screencapture": "1.0.0",
    "com.unity.modules.terrain": "1.0.0",
    "com.unity.modules.terrainphysics": "1.0.0",
    "com.unity.modules.tilemap": "1.0.0",
    "com.unity.modules.ui": "1.0.0",
    "com.unity.modules.uielements": "1.0.0",
    "com.unity.modules.umbra": "1.0.0",
    "com.unity.modules.unityanalytics": "1.0.0",
    "com.unity.modules.unitywebrequest": "1.0.0",
    "com.unity.modules.unitywebrequestassetbundle": "1.0.0",
    "com.unity.modules.unitywebrequestaudio": "1.0.0",
    "com.unity.modules.unitywebrequesttexture": "1.0.0",
    "com.unity.modules.unitywebrequestwww": "1.0.0",
    "com.unity.modules.vehicles": "1.0.0",
    "": "1.0.0",
    "com.unity.modules.vr": "1.0.0",
    "com.unity.modules.wind": "1.0.0",
    "com.unity.modules.xr": "1.0.0"

Managed to clear this issue by upgrading to a newer version of unity, only to be met with complaints from the render pipeline:

D:\Unity\Unity Projects\AtarBeta\Drawing\AlineURPRenderPassFeature.cs(4,29): error CS0234: The type or namespace name ‘Universal’ does not exist in the namespace ‘UnityEngine.Rendering’ (are you missing an assembly reference?)

Been fidling around with this for the whole day - reinstalling Core RP and universal RP to no avail. Switching from the Beta solves the issue, but I need to use the new recast features in the Beta.

I’m stuck :frowning:

I am using 2022.2.11 and I just upgraded from 4.3.61 to 4.3.63 and started getting the URP errors you’re referring to (previous version worked just fine). So you are not alone.

If I can I will try to downgrade to 4.3.62. In the meantime, I hope it gets fixed ASAP!!

1 Like

So downgrading to 4.3.62 did not work, but downgrading to 4.3.61 did work. I just edited the version number in the Packages/manifest.json file.

There are a LOT of changes in the 4.3.62 update, so I would like to eventually get that version working. It was released on the same day as 4.3.63 (March 19 2023 – yesterday).

1 Like

Agreed, the beta brings 4.3.62 brings with it some really nice enhancements that I am keen to try out. Namely the ability to tag a road “area” in the racast graph and have it hug the geometry better.

I copied the source out of the package manager, so I have a local version that I will try and fiddle with.


Make sure you are using at Unity 2022.2.10f1 or higher. Which version of the com.unity.render-pipelines.universal package are you using?

I went up to 2022.2.11f1, saw the error and decided to come down to 2022.2.10f1 to see if it would fix it. I’m using v14.0.6 of the universal RP. Thinking maybe a dependency missing in asmdef?

Here is a screenshot if the asmdef

Ah! I found the bug. I had removed some dependencies on the render pipeline packages by mistake. I’m uploading 4.3.64 as we speak. Hopefully that fixes it. It will be up in a few minutes.


Your asmdef file looks odd, though. The jobs dependency should be there. Are you sure you have the jobs package installed?

I believe that was because I was in safe mode. All working now with 4.3.64 :slight_smile: Thanks @aron_granberg

I can confirm - upgraded to 4.3.64 and all compiler errors are gone!

Uhhhh… Where did the Pathfinder script for making graphs go??? It’s just gone!



I can clearly see the file here: C:\Code\MyTestProject\Library\PackageCache\com.arongranberg.astar@4.3.64\Core\AstarPath.cs … so why can’t I add it as a component? It worked just fine in 4.3.61, then I updated to 4.3.64 and the file is gone. When I went back to 4.3.61 the file was still gone…

If I drag the AStarPath.cs script onto an empty GameObject it says:
But there are no compiler errors in the console.

Same with the RVOSimulator script… just gone. What is going on?

when I upgrade, I have the exact same errors that are described here.

forcing an upgrade of Unity Transport to [2.0.0-pre.7] gets rid of those errors, but that creates more errors somewhere else; I did eventually get all the errors sorted out.

not too crazy about using a preview collections version, that then forces the usages of even more preview packages :frowning:

Can you check the AstarPathfindingProject.asmdef file in the unity inspector. Does it show any dependencies missing?

Same problem here, I installed the latest beta version via UPM as instructed in the docs, it seems RVOController and Pathfinder scripts cannot find the VersionedMonobehaviour in the PackageTools package.

The dependencies on the AstarPathfindingProject asmdef look fine.

My solution compiles successfully but where AStarPathfindingProject scripts are attached my game objects I see this:

When I play the scene any code running AStar and calling “” blows up.

I tried to reference ALINE / AstarPathfindingProject / PackageTools via the editor in one of my projects .asmdef files and Rider cannot resolve the references as seen in the screenshot, just wondered if this helps narrow it down Aaron.

Also attempting to navigate to the VersionedMonobehaviour type through a code editor cannot find it either so likely a missing or broken reference

first missing ref is ALINE and second is PackageTools.

I can confirm though the beta is working in a fresh URP project using Unity 2022.2.11 using the process you describe in the beta installation instructions.

Similar problems here as above, can’t use A* at all due to this. Looking forward to a fix! Can provide more info if helpful, thank Aron


I cannot replicate this, I’m afraid.
Would it be possible for you to send the contents of your manifest.json file so that I can replicate your dependencies as closesly as possible? Also your unity version.

Ive tried building a few new projects now and it seems to be fine, something is unhappy in my main project so im rebuilding it, it frustrating but I do not think this is your fault.

Okay. Let me know if rebuilding it works for you.