Moving ALINE folder

I updated to the latest ALINE today and noticed it won’t anymore work having the ALINE folder moved to another folder, it seems like it must be in Assets/ALINE now?
It seems like DrawingSettings.cs is the issue?

Is this a known limitation recently?


If it is a limitation, it’s not one I have introduced intentionally.

What makes you think DrawingSettings.cs is the issue?

Sorry, it worked by just fully remove it re-download it.
The issue happened when I had a moved the folder, update to the latest version it put the ‘DrawingSettings.cs’ it the asset folder and not where the Aline was moved to.
And then moving the DrawingSettings.cs into the moved Aline folder it started throwing error it could not find DrawingSettings.cs and after that URP spamming errors.

Either way, it’s working with a fresh Aline install.

It came back after a restart, the console spams this:

:warning:: No script asset for DrawingSettings. Check that the definition is in a file of the same name and that it compiles properly.

:stop_sign:: InvalidOperationException: ALINE settings could not be found
Drawing.DrawingData.Render (UnityEngine.Camera cam, System.Boolean allowGizmos, UnityEngine.Rendering.CommandBuffer commandBuffer, System.Boolean allowCameraDefault) (at Assets/3rd-Party/ALINE/DrawingData.cs:1257)

:stop_sign:: Exception: You cannot dispose an invalid command builder. Are you trying to dispose it twice?
Drawing.CommandBuilder.DisposeInternal () (at Assets/3rd-Party/ALINE/CommandBuilder.cs:245)

:stop_sign:: Render Pipeline error : the XR layout still contains active passes. Executing XRSystem.EndLayout() right now.
UnityEngine.Rendering.RenderPipelineManager:DoRenderLoop_Internal (UnityEngine.Rendering.RenderPipelineAsset,intptr,UnityEngine.Object,Unity.Collections.LowLevel.Unsafe.AtomicSafetyHandle)
ProjectVik.Game.EnvIntRenderTextureCamera:Update () (at Assets/Scripts/Game/Camera/EnvIntRenderTextureCamera.cs:58)


Can you check if you have the Assets/Settings/Resources/ALINE.asset file? And if you do, try deleting it.

Removing that and a Unity restart did it, thanks!

Spoke too soon, another restart and it’s back. Deleting the ALINE.asset and restart works for one session each time.


Hmm. Do you have the AstarPathfindingProject installed as well? I know that for some very specific versions, there is a conflict between them that might cause this.

I tried updating to latest beta, same thing though.

I just noticed that after the Unity restart, Assets/Settings/Resources/ALINE.asset say it can’t find the script in the insepctor. So I’m guessing when restarting either Astar or Aline make a new one and there is a conflict?