Support Forum

Min region size failure

360截图20210206142429974

Hi, no matter how I change it, min region size can’t work normally. I’ve updated to the latest version, but it still can’t work normally. There’s no response. How can I get rid of the middle part? Thank you very much!

I clicked the Generat cache and Load from cache buttons
EndLayoutGroup: BeginLayoutGroup must be called first.
UnityEngine.GUILayout:EndHorizontal()
Pathfinding.AstarPathEditor:DrawSerializationSettings() (at Assets/AstarPathfindingProject/Editor/AstarPathEditor.cs:817)
Pathfinding.AstarPathEditor:DrawMainArea() (at Assets/AstarPathfindingProject/Editor/AstarPathEditor.cs:383)
Pathfinding.AstarPathEditor:OnInspectorGUI() (at Assets/AstarPathfindingProject/Editor/AstarPathEditor.cs:262)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Hi

This can happen if the region touches a tile boundary. In that case it is impossible for it to remove the region because it may be connected to an arbitrarily large region in the adjacent tile.

However, this region looks like it is inside an object. In the beta version colliders are treated as solid instead of hollow, so no navmesh is generated inside colliders. Maybe that will help you?

Sorry, My english is not very well.I didn’t remove the middle part after I tried. Here is my screenshot. Maybe I misunderstood it?

Hi

What I mean is that, yes, this is expected.
You can use the beta version to solve this. You can download it here: https://www.arongranberg.com/astar/download

I see. Thank you very much!

Im sorry to bother you,I downloaded the latest beta version, but it still didn’t solve the problem.

Hi

Do you think you could show a screenshot from an angle? It’s kinda hard to see how your scene is laid out.

Unity 2019.3.15 version, I created a 300x300 terrain with a height of 100. I didn’t change other options, which are the default settings. Then I created a cube.1

Aah, the navmesh is on top of the cube. I thought it was inside it.

If you want to remove the navmesh on top of an object, the right solution is to attach the RecastMeshObj component to the object and mark the surface as unwalkable.

It is running well at present, thank you!

1 Like