Support Forum

Issue with AI bounds (not sure if thats the right term)

Hi all,

I have an issue with my ai. A* for some reason decides that the model is always above 50% of the actual mesh, leading to the issue you see below. I can resolve this somewhat by making the object a trigger, but this is by far a less than ideal solution and I would like to find a way that I can lower the orange gizmo down so that it fits my mesh perfectly. The mesh is just the default unity capsule atm, but this issue persists with every model I have tried so far. Below this image are my A* settings, then the settings on the unit that is shown.

image


Hi

The agent’s pivot should always be at the agent’s feet. This is a deliberate decision because it makes many calculations much less complex, and in my experience it just makes it much less likely to shoot yourself in the foot later.
You can make the capsule match the yellow cylinder by putting it on a child object and then moving it up a bit.