Issue with a huge gap across the whole level

first of all, I am really new to using A* pathfinding Pro and my issue is most probably caused by me not understanding something :)) but I am out of ideas so I would appreciate any help!

I am using the recast graph for my level, I am using both meshes and colliders to generate it. It worked fine for some time but as the level grow (or maybe as I was playing with the settings), the weird thing started to show: the un-walkable gap which goes along the whole level.

It would make sense if in its place there would be something causing it, but there are no game objects, no meshes, no colliders, nothing. Just floor. Also the floor is just one big plane, it is not composed of multiple parts. I can’t find any reason why it would generate like that.

I think it is connected to the placement of the graph, because pressing “Snap bounds to scene” fixes it. Anyway I can’t use that as with this setting the graph is too tall and marks as walkable (blue) also for example the top parts of some objects (e.g. table desk). This behavior is also a mystery to me as they have box colliders and should be unreachable I think.

Thanks for any help!

Just a small update, I’ve tried looking into it a bit more, and even after deleting literally everything from the scene (keeping only one quad and the pathfinder), the behavior still persists

Changing the size of the recast region changes the shape of the ridge, like in this case where I only changed the y size to 10

edit: It only seems to happen with a Quad, doesn’t happen with e.g. a Cube.

It may be a precision issue with slope limit 0, try setting it to something just a little higher.


Yeah, as @Polymo says I think that is the most reasonable cause. Those triangles might be detected as having a slope of 0.0000001 or something.

1 Like

Wooow thanks, I would not have figure this one out not even in a million years :smiley: Thanks a lot for the reply, I appreciate that!

1 Like