How do I Ignore Trigger Colliders


I am using a Layered grid graph with tags to determine what seekers can and cannot walk on. For each object placed on scene during runtime, I make a call to update graph object accordingly.

Problem I am having is that I have an object meant to be a door. It needs a trigger collider, vs a regular one, in order to actually let seekers through. As a result, I have one trigger collider on it to represent outline of object for placement, and another to represent area that will trigger the door to open because someone is about to walk through.The latter is much larger as it needs to detect people coming from a distance in order to open the doors in time.

When the graph scans though, I notice in Scene view, that it color codes the top of the door open trigger collider, with a color. This causes seekers to not be able to walk through it.

I did see some previous posts on this topic, but they were 3-4 years old. Anything more recent on how to deal with this by any chance? Thanks.

Little more information. The door open trigger collider I mentioned above, which is larger than the door itself, is overlapping with colliders for other objects. This is causing astar graph to color code some tiles halfway in height between the top of the door trigger collider, and the collider of the object being intersected.

Picture a door with a meter of space in front of it, and then river. I have the river tagged as unwalkable, but a boat can stop and let people off, right in front of the door. The door trigger is long and seems to be overlapping with the river tiles, hence causing the wierd color coded tiles halfway in height.

I could make the door trigger smaller, or just place it further away from river, but I feel like I am going to keep running into this issue in the future. Would love a more bullet proof solution. I also cannot disable trigger collisions globally, as it would break other parts of the game.

Please note that the larger, door open trigger, is a component of a child transform of the door, not the parent. It is also tagged correctly as a tag that should be ignored by seeker.


You can either:

  1. Disable ‘Queries Hit Triggers’ in the Unity physics settings

  2. or put the trigger object in a separate layer and make sure that layer is excluded from the height testing and collision testing masks on the grid graph.

1 Like

Hi Aron, this is an older thread. Are these two solution the only ones or is now in 2022 another (maybe) better solution for this?


Trigger colliders are always ignored in the latest versions.