GridGriph configuration being reset to default on play

Whenever I press play the inspector configuration of the AStar object get reset to zero. Specically I’ve modified the nodeSize and height testing/ray length.

I’ve worked out how to set them to what I want in the OnGraphPreScan event, but I’d rather be able to set them in the inspector.

Is this standard behaviour? It seems to happen even after removing/deactivating all my code that touches the AStar object.


That seems very odd. What version of Unity and the A* Pathfinding Project are you using?

PS: Sorry for the really late answer, I have been away for a while and haven’t been able to answer many questions in the forum.


Sorry for reviving this topic but I’m facing simillar issue now.

I’ve set up pathfinding without any problems and everything was working correctly, altrough not compiling on Windows Phone. I’ve enabled ASTAR_NO_ZIP, ASTAR_NO_JSON and removed unnecessary dlls as stated in documentation.

Now after hitting play in Unity editor GridGraph is resetting to default settings without any errors or warnings.

Out of curiosity I’ve still tried to run it on Windows Phone to check if there are no compilation errors in Visual Studio.
Game is starting just fine but no Graph is found.


Are you using cached startup? If you are doing that then it will load the cache every time you press play.

Does this give you any error messages?