GraphUpdateScene Not Working

I’ve just purchased this asset specifically to make use of the GraphUpdateScene component that the Unity navigation package is missing.

I have read through all the tutorials and everything else such as grid obstacle are working fine. I have watched the video on using these and read every page of the documentation. I also found another thread where someone had issues and tried making use of the following;;

I have the graph set to show Penalty and I’ve tried every variation of the GraphUpdateScene component and am not seeing any change to penalty, walkability, or tag.

I’m on Unity 2022.3.3f1 using the latest beta version of A*

Any assistance would be greatly appreciated, thanks

I’ve attempted to set this up in a fresh project in 2022.3.3f1 and it is still not working so it seems to be a bug or I’m missing a step


Could you include some more detail about how you have set it up, which graphs you are using, etc.?

While setting it up again and trying to grab pictures and things I ended up holding shift to add new points and dropped one down adding a third point and now it works.

So it looks like the issue is having 1 or 2 points set doesn’t work, You should consider adding a warning for that because when you have 2 points filled in it draws a cube and removes the warning about having no points but it doesn’t work.

Another question… I’m not sure it’s creating any issues but I get a message when I recompile based on the number of times I’ve hit play from the RVO Simulator.


1 Like

This has been fixed in the latest beta.