Graph disappears after exiting play mode

Hi Aaron, I’m just seeing this weird issue in the latest stable release:

  • Select the Pathfinder GO
  • Generate a cache (the graph is visible)
  • Save the graph as a file (within the Assets folder)
  • Check the Cache startup option
  • Enter play mode. Everything’s normal
  • Exit play mode: the graph disappears

At this point if I re-enter play mode the characters won’t move since it appears there’s no graph (although I get no errors about a missing graph or anything). So I have to click on “Load from cache” every time I exit play mode or I enter play mode to regenerate the cache. Surely I’m doing something wrong here…?

(Just in case this isn’t clear, the expected behaviour would be for the cache to simply remain as it is when I exit play mode)

Please note that I also tried without the “Cache startup” option to no avail (same behaviour). I also thought that maybe it was linked to Unity’s “fast enter play mode” but I also tried with the normal enter play mode and it’s still happening.


Hey @aron_granberg I’m still stuck with this and I think you might have overlooked this message. I need your help please…


Sorry for the late response, I did indeed miss this message.

What exactly do you mean by ‘the graph disappears’. Does it disappear in the scene view or does it also disappear in the A* inspector and you have to configure all settings again?

Can you replicate this in an empty scene by following the sequence listed above?

By “the graph disappears” I mean the navmesh disappears from the scene view when I exit play mode. And if I enter play mode again without doing anything (like reloading the graph) then agents don’t move anymore because there is no navmesh visible in the scene.