Support Forum

Get Started Documentation - Tutorial not working

I’ve been following this documentation Get Started and I’ve read through it and followed the steps a few times now with no success. I’m at the step Adding the AI but when I press play, nothing happens.

Checklist:

  1. Plane at World position (0,0,0) scaled to (10,10,10) on a new Layer called “Ground”
  2. Several Cubes added on the plane on a new layer called “Obstacles”
  3. Game Object named A* added to the scene, with the Pathfinder component, Grid selected, width and height at 100x100, center set to (0, -0.1, 0), obstacle layer mask set to “Obstacles”, Height testing Mask set to “Ground” everything else unchanged
  4. Click Scan - everything looks good
  5. Add Capsule Game Object to scene and name it Target
  6. Add Capsule Game Object to scene, Add Character Controller component, Add Seeker Component, Add AIPath component, and AI Destination Component. Drag/drop “Target” game object to the Target of the destination component.
  7. Hit play, get a green line showing the path, but nothing moves.

Screen shot:

I noticed a few things, but messing with them didn’t seem to change anything. Here is what I’ve tried:

  1. Removed the default Capsule Collider on the AI
  2. I noticed the AIPath is drawing a gizmo that is floating midway up the capsule
  3. Saw in the youtube video tutorial that the cylinder used was nested under an empty game object with the AI components. So I tried that with the capsule with the AI components on the parent.

Any help is appreciated.

Do you get any errors in the console?

No, the only output in the console is the debug messages for the scanning process and the path computation

In case it helps any, running Unity 2019.4.38f1 on URP

Could you show me your AI GameObject?

Sure, here is a screen show with the components expanded. Current iteration I have just disabled the capsule colldier

You don’t happen to have the project’s time scale set to zero or something? Or the gravity in the project turned off?

Just checked that. I swear I just created this project to try out this and another asset, and the time scale was indeed set to 0, but I cannot for the life of me understand how that happened. I’ll check out the other assets that I added to this project and see if any of them set the timescale to 0 when I imported them

Also, thank you for your help and amazingly fast responses.

1 Like