FollowerEntity not moving if the path is set with SetPath

Hey! I am not sure how to move the agent with FollowerEntity using SetPath() method. Previously I was using AIPath and SetPath() worked great. I need to use paths as I have citizens which need to flee from attackers and choose random path if there are no attackers. FleePath and RandomPath worked great for it. However, trying to optimize on older mobile devices, I decided to switch to FollowerEntity and test the performance there. I replaced the AIPath with FollowerEntity in my code and deleted the Seeker, AIPath and RVOController from my citizen objects and added the FollowerEntity component. The problem is that now the agents are not moving at all. If I use SetDestination() instead of SetPath(), the agent works, however as I need the FleePath functionality, I would prefer to use SetPath(). Is there anything I missed? My current version is 4.3.97.

Any help on this would be greatly appreciated. I think it’s a bug because it doesn’t work if I change to SetPath() in Sample scene as well. If needed I can provide an invoice number to confirm purchase.


Sorry for the late reply.

Yes, this was indeed a bug!
I’ve managed to replicate it, and a fix will be included in the next beta update.
Thank you for reporting it.

Thanks for the response!