Error "Graph Count Limit Reached. You cannot have more than 3 graphs"


Looking at this error:
“Graph Count Limit Reached. You cannot have more than 3 graphs”. I only have 2, and looking at the code it is doing a -1 on the limit (not sure why). The documentation says I can have up to 16.

It says I can change this value in the optimizations tab. Opening this tab only gives a message with an apply and refresh button. There is no option to change the max graphs.

I could hard-code this change, but I don’t want to break anything.

Please advice how I can go about bumping the number of graphs I want up.



Yeah, I am afraid the docs are a bit out of date on that point. I changed from 16 to 3 graphs because almost no-one was using many graphs, but they were hitting another limit. Since I use a bitfield for those numbers, I decreased the number of bits for one thing and increased it for the other.

Do you use the pro or free version?
In the pro version you can change this option:
To give you 32 (or maybe 30) graphs that you can create.

I have the pro version, but this is all I have available to me under optimization:


Could you try uploading that somewhere else? It doesn’t seem to load for me.


Hm, that’s odd. Are there any errors in the log?

And in any case. What you can do as a workaround is to open the GraphNode.cs script and look at the top, there should be a line looking something like
Comment out that line.

Wait…There is an error when I open the tab:

Directory does not exist (C:/Game/Assets/AstarPathfindingProject)

I did a fresh update and import and the folder comes in as:


Ok ill do that

Ah, you have enabled Javascript support, am I right?

Yes! Disabled it and now its working with those options. Thank you


Ok. I have fixed the bug that was causing it not to work when JS was enabled.

Love that turnaround time!