Doesn't detect obstacles. + grid thickness setting?

It seems like A* Pathfinding doesn’t detect any obstacles. I have placed them in Obstacles layer, placed little under the actuall terrain, enabled thick raycasts, but nothing helps.

Also, is it possible to adjust grid graphs line thickness? It is really hard to see it on anything other than untextured plane.


You need to set the ‘Collision testing’ raycast mask to something other than ‘Nothing’. Currently it is configured to detect absolutely no obstacles.
You probably want to exclude the obstacles layer from the ‘Height testing’ mask as well to prevent the grid from being generated on top of the obstacles instead of on the ground.

If you have 3D gizmos (or 3D Icons as I think it is called in some version of Unity) enabled you can try disabling that to increase visibility. There is unfortunately no way to increase the thickness of them (they are drawn using a Unity API).