A* Pathfinding Project

Default Constructor not found for type Pathfinding.GridGraph


#1

Hi Guys

I play around with a small Maze TD (2D) and using A* for my enemies. I finished my game on normal build and everything works fine. When I change my build for WebGL I get a weird crash:

I tried a lot of different approaches, but can’t really pinpoint the problem within webGL and my Game… Has anyone experienced something similar?

Thanks a lot in advance! Ori


Runtime error on Android Build
#2

Hi

It might be that some stripping code removes the grid graph constructor. Try to follow the instructions for iPhone here: https://arongranberg.com/astar/docs/iphone.html, specificially the link.xml part.


#3

Hi Aron, thanks for the instant reply!!

Unfortunately, neither the link file under my assets folder nor the disabling the default “Strip Engine Code*” option under Player Settings helped. Do you have any other idea what I could try?


#4

Hi Aron,

Problem solved (and another occured - which I think is not related anymore to your aStar). I changed the “Strip Engine Code*” to “Low” and with that and your link file together it works! Thanks a lot for the instant reply and your support!!

Best regards, Ori