Dedect inner small Rooms as no Walkable

Hey there,

when i make a room with Walls (Walls not walkable) then the room inside will also marked as unwalkable also when it is no obstacle layer.

how to fix this?


Could you show a screenshot of this?

sure. here is a picture.


Are you sure the collider really only occupies the border of it? My package uses Unity’s built in physiscs functions for this, so they should be accurate unless there’s a bug in Unity.

Yes im sure. when i remove the border it works. like in picture…

its weird…

Are you sure Unity’s tilemap system doesn’t optimize the collider to cover the whole room? I think there’s some setting for that.

i i dont know… in editor mode i cant see thats there is a collider in the inner room. and i dont know where to check if it should cover

i tested again and just copied the same tiles. and look. sometimes it works with inner map…

are you sure that the isse is not from astar?

There are some other users that seem to have found different solutions, see the thread linked below, it might help you.