Support Forum

Compilation errors with version 4.2.15 and Unity 2019.3.12f1

I’m surprised I seem to be the only one having this issue, so I’m probably doing something wrong. To rule anything project-specific out, I created a brand new project. I performed the following steps to do the installation:

  • Created a new 2d unity project.
  • in Assets -> import package -> custom package… I selected the package I downloaded from the downloads section
  • I left everything selected and clicked Import.
  • Now when I open my project’s solution and try to compile, I’m getting a great amount of compilation errors, the first one being:

|Error|CS0246|The type or namespace name ‘VersionedMonoBehaviour’ could not be found (are you missing a using directive or an assembly reference?)|PackageToolsEditor|C:\Users\HaNS\Documents\Projects\test\Assets\AstarPathfindingProject\PackageTools\Editor\EditorBase.cs|8||Active|

It seems like all the dependencies are missing.

The thing is, I don’t even want to compile the Astar project. I’d be perfectly happy if the astar project isn’t part of the visual studio solution (if that makes any sense), but every time I try to delete it from the solution, it reappears, and I don’t really know how I should separate it from the solution.

As stated in the title, I’m using Unity 2019.3.12f1 with version 4.2.15 of the Astar project.
Let me know if you need more information.

I upgraded to Unity 2019.3.13 and that fixed the issue.

You are not the only one.
Here are some other threads



I’m glad you figured out what the issue was :slight_smile: