Can't get ALINE to render on URP


We are having trouble upgrading ALINE and UNITY.

Our project uses URP and on Unity 2020.3.30 with ALINE version 1.4.3 everything seems to be in order.
Upgrading said project to 2021.1.x breaks ALINE (nothing is rendered).
Upgrading ALINE beyond 1.4.3 breaks on 2020.3.30 and any later versions we tried (nothing is rendered).

Currently I’m trying to get ALINE 1.5.3 running in 2020.3.30 using the template project provided by Unity. Frame debugger shows ALINE issuing draw calls, however nothing is rendered neither in scene view, nor in game view in play mode.

Any suggestions on what to look out for?


Sorry for the late reply, I’ve been sick these last few weeks.
Which operating system are you using?
Are you using any post processing effects or other non-default settings for the URP?

OS: Windows.

This reproduces in the default URP example (template project) provided by Unity.


Hmm, I cannot reproduce this.
I opened the template project, imported ALINE and added the GizmoSphere example script to the scene. It shows up perfectly well.
Are you sure gizmos are enabled in the scene view/game view?

I tried it in both in Unity 2020.3 and Unity 2022.

Unfortunate :frowning:

It even shows
Shader error in 'Hidden/ALINE/Outline': unrecognized identifier 'line_v2f' at line 33 (on d3d11)


Dug some more and found something interesting:
ALINE 1.4.3 works in 2020.3.37 by default.
ALINE 1.4.3 works in 2021.1.23 if you change DrawingManager.cs BeginFrameRendering cam.TryGetComponent<UniversalAdditionalCameraData>(out UniversalAdditionalCameraData data) to cam.GetUniversalAdditionalCameraData(), which you have already done in a later version.
ALINE 1.5.3 has shader error mentioned above. Replacing aline_common.cginc include with aline_common_line.cginc fixes the error, but doesn’t make gizmos show up.


I’ve published a new version of ALINE now. Do you think you could try it?


Version 1.6 works!
However I still had to modify aline_outline.shader includes to use aline_common_line.cginc instead of aline_common.cginc because line_v2f was not found.


Great! But aline_outline.shader already references aline_common_line? Are you sure you installed the package correctly?

Hmmm, do you have the A* Pathfinding Project also installed?