Can't find path lower than MaxClimb despite node connection

A small problem, the pathfinder can’t find a path lower then MaxClimb even though there is Node connections, if there is no walkable path.

I create my own connections, diagonal and jump up/down (LayeredGridGraph).

With step(left), it can jump down as it should, even if the step is out of reach.

Without the step it can’t jump down.

However the ConstantPath (the spheres) always finds all positions in range.

Can I disable the MaxClimb check and only follow the Node connections when checking for a path somewhere?


How do you add the custom connections?

First I clear the node with
then add the connections I want on the node with
FromNode.AddConnection(toNode, cost).

Do you do this inside a work item as described in Graph Updates during Runtime - A* Pathfinding Project? AstarWorkItem(() => {
    // Safe to update graphs here

No I did not. A tiny detail I’ve missed. It works as it should now. Thank you.