Support Forum

[Bug] A* Gizmos visible in Prefab Mode (isolated)

This isn’t the biggest issue, but the A* gizmos are being drawn even in isolated prefab mode when I have a scene opened that contains AStarPath. I am seeing the grid at all times (2020.2.2f1 + HDRP 10.2.2). If I open up a scene without AStarPath and then enter the prefab mode the gizmos are gone as they should be.

Using Pro version 4.3.39

Hi

Could you post a list of instructions on how to replicate this? I just tried this and I cannot replicate it.

Sure. I tested it on my machine and I can reproduce it.

Steps I’ve followed:

  1. Create a new project. I used Unity 2020.2.2f1 with HDRP template
  2. Add an A* Pathfinding Project. I am using the pro version via UPM, so I added a scoped registry and manually added an entry to the manifest.json since my unity cannot recognize it despite I added the registry via the editor gui. I used the latest version 4.3.40.
  3. Create an empty game object in the scene and add a Seeker component to it. Then create a prefab from it by dragging it to the project view.
  4. Create an empty game object in the scene and add a Pathfinder component. Create a new graph. I’ve added an LayeredGridGraph with the size of 150x150 on a new hdrp template scene.
  5. Enter the prefab in the isolated mode by double clicking on it from the project view.

You should see something like the screenshot I posted above.

Were you able to reproduce this behaviour? Can I do anything else to help?

Hi

Sorry for the late answer.
Thanks to your instructions I was able to replicate this and write a fix.
It will be included in the next beta version of the package. :slight_smile:

1 Like

Oh and btw, yes I do read the survey responses people send in :slight_smile:

1 Like