Support Forum

Ai stuck inside graph (inside a bigger graph)

Hello!

So I have a big graph in my scene, and a smaller graph located inside this big graph for other purposes. An AI uses the big graph, but as soon as it enters the small graph, it can’t come out of it - stuck at the small graph’s edge like there’s a wall, but still calculating the right path to the target. I tried to uncheck the “constrain inside graph” parameter, but it doesn’t change it. It really seems odd since this AI isn’t supposed to use the small graph at all.

I hope there is a simple solution that I missed? Having a small graph inside a bigger one seems to me like a classic use of the system no?

Thank you for any help :slight_smile:

Hi

The agent will always try to use the graph that is closest. If you have multiple overlapping graphs I would recommend that you explicitly specify which graph the agent should use, using the Seeker → Traversable Graphs setting. Generally a single graph is better unless you need multiple graphs.

Hello, thank you for this quick response!

However, yes the Traversable graph is already set to only the big graph (graph0 here, graph1 being the small one)