AI not "using" their collider

I didn’t know how to ask, but when i scan for paths, everything is right.
When i want to move my character in this path, it’s right, but it doesn’t work because it is (maybe) thinking that i have a little collider, but my cube is a fat boi, so no.
So if it moves while thinking i have a little collider, this happens:

it justs makes a good path, but doesn’t take care of my collider…
Maybe it’s stupid, or -i don’t know what-, but i’ve been looking for answers for hours.


You’ll want to change the collision check parameters on the graph. Under the section collision testing you can play with the values like diameter, height and offset. You preferably want to make these similar to your moving object.

Hope that helps

In 2D, i can use only :

So idk what to do…

I haven’t used the 2D components myself but the collider type can be set to Sphere (or circle) instead. Point only checks if the middle of the GraphNode is walkable, while sphere will check in a small circle around the center


It looks like you don’t have a sufficient margin in your grid graph. Try to increase the Diameter setting in A* Inspector -> Grid Graph -> Collision Testing.
Your grid graph also has a way higher resolution than necessary.

Also see