AI not moving to destination

Hi! I’m very new here and I just want to first say that this ai pathfinding is so helpful and awesome but there’s just one problem… So i have the ai path + destination setter but the ai is not moving towards it. however it is calculating the path towards the target


Have you checked out the example scenes? It could be helpful to look at how it is done there so that you can compare.

Hi! Thank you for the quick reply! I just did check and changed the ai path to a lerp instead and it worked! Thanks! but there’s one weird thing happening… what i’m doing is just a simple floating object that follows the player, kinda like a pet. now, the lerp is working fine but when im moving straight the ai looks like it’s lagging behind for a bit then moves again so it’s like jumping frames and doesn’t move smoothly. is there any way to fix that? thank you again!


Maybe it is not recalculating its path often enough?

i’ve set it to 0 and it’s still like that :frowning: i’m starting to think that maybe it’s my laptop. however, I tried your example 2d scene and it does not act like that… also i’ve tried replacing the aiLerp on your 2d example scene with the AI path to test it out but the ai doesn’t move. Thank you again!