AI is trying to path through walls

This is my first attempt to use this resource. I followed the tutorials and created a pathfinder graph; it is properly identifying the parts of my scene that can be traversed and which are walls.
I tied to use the existing AI behaviors that came with the package. I disabled the script I had previously written to control the “enemy capsule” in my scene, and added the AIPath, Seeker, and AI Destination setter scripts tot his object. I set the target destination as the player. The default shape matches what I have in my character controller, so I didn’t change anything else.

When I run the game, this enemy just stays stuck in its starting position. If I move the player close enough I can see the enemy trying to move in a beeline to the player, but its stuck by the walls, and it slowly moves the minute difference between the angle of the wall and the angle to the player.
I tried disabling some of the collision and confirmed that the enemy is indeed just trying to move directly toward the player, not at all trying to pick a path around the objects in its way.

My game is natively set up in a grid; everything is made up of 1x1 squares and divided into narrow corridors with no diagonal movement possible. The path for the graph nicely fits this designation as all the blue squares that show up on the graph fit the tiles in my game world.

Please advise.

A bit difficult to diagnose without seeing the project. Please post some screenshots.

Is the Obstacle Layer Mask field properly set in your Graph ? Should be set to the layer for obstacles and walls.

Yes it is; the blue tiles for the path appear on the walkable spots while the red boxes float above all my walls.
And even if it were not, the colliders are so high that the AI should not interpret them as a “floor” they can reach.

If the graph is coloring things right, then I would guess the problem is with the enemy’s script not seeing the graph.
Here’s the scripts I put on the object. Is there something I have set wrong?

I have tried starting over again from the beginning on a completely separate map just to ensure that I didn’t have something weird, like accidentally making a second pathfinder grid. This is also a much simpler level where everything is nice and flat and the correct path is plainly visible.

But on this second map I am still having the same problems; the AI is ignoring the path and just trying to walk into walls.


I would recommend trying to reduce your Pick next waypoint distance. That will make the agent follow the path more closely.