Support Forum

AI does not path to target when he is upstairs

So I have a target that is standing on the first floor, a AI on the ground floor that follows the target and setted up A* Grid Graph, however when the AI is moving to the target the AI just moves to the position to the target and stays underneath him instead of pathing where the target exacly is. I have AIPath and AI Destination Setter on the AI, setted up A* Grid Graph Height testing mask to Ground (stairs have that mask). Is it caused because of how Grid Graph sets up the graph like in this image(stairs graph): https://prnt.sc/11rgmta

Hi

Yes that looks like the ramp is too steep.
You can try to increase the grid graph -> max climb setting and/or the max slope setting.

In the beta version the handling of slopes is also improved to reduce issues like this.

I tried setting the max climb and max slope settings to different values but still same result, the AI just goes underneath the target. I made a video how I it looks. https://www.youtube.com/watch?v=MzAYPbPUUco

Hi

Hmm, it’s very strange that it goes outside the graph there. I’m not sure what could cause that.
Judging by your grid graph settings your max climb setting is definitely too low. You should be able to visibly see that the nodes on the ramp are connected.

Maybe I could try and post the scene here, maybe I am doing something wrong(which I might because Im just beggining to work with A*) and you could check whats wrong because its weird that I can’t set up a AI that can’t walk upstairs to the target…

Hi,

I’m not totally sure but I think I’m having a similar issue: essentially I can’t get the graph to include the ramp when generated (although I’m using a Recast Graph).