Agent always following same path even when using modifiers


I’m using a recast graph but treating it as grid graph since I’m using grid system to build my 3d village. All the objects are instantiated at runtime. so this is the scene after placing some objects -at runtime-:

[deleted image]

I’m using GraphUpdateScene component on each object either to define a tag or to define nonwalkable areas. The dark green grass has a 6000 penalty tag while the sand has no penalty. So the agent will always prefer to walk on the sand to reach his destination.

The problem is the agent is always using the shortest path hence he is always walking on the sand but adjacent to the grass. and always following a blue line instead of the green one:

[deleted image]

I tried to use RadiusOffset with Funnel and this is exactly what I want, but still the agent is following the same blue line:

I also placed a nonwalkable tag on the agent’s path. The agent always following the blue line like following:

[deleted image]

I tried to modify many values and playing around with different modifiers. Some modifiers have changed the path that the agent would follow but the path was crazy =)

Am I missing something?

Here are some informations that maybe useful:

A* v4.2.15 Pro

[deleted image]

[deleted image]


PS: I realized I can only post two images so I deleted the rest.


The RichAI component requires its own internal funnel modifier because it does movement in a way that is more than just following a list of coordinates. If you want to use other modifiers, I would recommend that you use the AIPath (or AILerp) movement script instead. Sorry if the documetation is not super clear on this difference at the moment.