A* Pathfinding Project

60FPS on 2018 iPad Pro


#1

Hi!

First of all I love this asset!

Second, I am doing something devastatingly wrong.

I have a iPad Pro 2018 12.9in. I want to run my game at 60fps (when I move my artwork looks blurry at 30fps).

I have confirmed that a* asset is the reason I cannot run at 60fps as I built a scene with and without it. (I am only moving a character around on the screen, nothing else is happening with my code)

The scene I have with a* is simply a grid graph (with a RVO simulator) with no enemies even on the map and I run at or below 30fps.

What am I doing wrong?

Thanks!


#2

I can only post 2 images as a new user. Here are the images of my enemy prefab.


#3

Hi

Which version are you using?


#4

Thanks for the quick reply!

I am on version 4.2.2. (Here are two more screenshots of the grid graph settings/optimizations)

When I click update to new version in the inspector I get a 404 error on the page.


#5

Hi

Okay. Try to upgrade to the latest version. (https://www.arongranberg.com/astar/download) Here is a quote from the 4.2.4 changelog:

Fixed a massive performance regression when using RVO together with IL2CPP and .net 4.6 due to changes in how the .net framework handles locking internally.

Which I think is what is causing problems for you.

Oh. A 404 does not sound good. Do you think you could post the URL that gives you the 404?


#6

I will try updating and come back with the answer. Thank you so much!

http://www.arongranberg.com/astar/download


#8

Ah, that was a bug in my server config. It didn’t work with the www part unless you were using https. I have fixed it now (and the ‘cannot connect to server’ message that you got for a moment there was just because I had to restart my server software).

Thanks for reporting it!


#9

np! And that update definitely worked thank you so much!


#10

Awesome!

Also, if you feel like supporting the development of the package even more, a rating and/or a review in the Asset Store goes a long way :slight_smile: